Website loading issues

Minor Incident Derby (UK 1) data centre Maidenhead (UK 2) data centre Poole (UK 3) data centre London (UK 4) data centre London (UK 5) data centre Gunzenhausen (DE) data centre New Jersey (USA) data centre
9 days, 7 hours, 41 minutes

Update

Resolved

All issues resolved as-of 8th May.

May 16th, 2019 19:52 BST
Investigating

Some visitors are currently experiencing issues where websites are failing to load. This intermittent issue is currently being investigated.

May 7th, 2019 12:11 BST